When I transfer files to cavatica the portal says it worked but the files don't show up

Where is the bug?

Issue Description

When I try to transfer files from the portal to Cavatica, the portal says that I successfully moved files to cavatica, yet when I look in cavatica, the files do not show up. I’ve already double checked that my portal account is connected to both gen3/era commons as well as cavatica.

Expected Behavior

The files should show up in cavatica when the portal says they are transferred.

Actual Behavior

The files are not showing up in my cavatica project (even though the portal shows the projects.

Have You Tried Any Troubleshooting On Your Own?

  1. I double checked (and disconnected and reconnected my portal account to gen3 and cavatica.

Your environemnt

  • Operating system: MacOS,
  • Browser and Browser Version: Firefox 81.0.1

Other Notes

If there’s anything else you want others to know about this issue, this is a great place for that.

We investigated this problem with a user and discovered that it occurred because their Cavatica account was not created with their eRA Commons ID, which is required for authentication to transfer files. We advise all new users to create their Cavatica usernames via eRA Commons whenever possible.

We confirmed this by checking the username dropdown in the top right of the Cavatica window, choosing “Account Settings,” and then Dataset Access. The Kids First Controlled Datasets listed were all shown as unavailable with red X’s.

To resolve the issue, we clicked the blue “Upgrade my account” button on this same page, integrating the user’s Cavatica username with their eRA Commons ID. This allowed for authentication to take place in the system and allowed them to transfer the files from the Kids First Portal successfully.

1 Like

Great! Now the Dataset Access Page on my cavatica account says " Connected to Gen3"